Mruganie świateł na filmie z makiety

Prąd i elektronika na makiecie

Moderator: mod-Elektryka i DCC

gemol
Posty: 966
Rejestracja: 10 kwie 2006, 10:33
Lokalizacja: Radom
Been thanked: 2 times
Kontaktowanie:

Re: Mruganie świateł na filmie z makiety

Postautor: gemol » 06 cze 2014, 08:54

Teigrek ma nawet światła awaryjne. ;)


Awatar użytkownika
A_Tox
Posty: 62
Rejestracja: 11 paź 2006, 10:17
Lokalizacja: Gdańsk

Re: Mruganie świateł na filmie z makiety

Postautor: A_Tox » 05 cze 2014, 11:04

whosho pisze:Dopiero stabilizacja i filtrowanie wyprostowanego napięica pozwala uzyskać "kreche" ;)
Zasadniczo należy stosować mostek Graetza. Pulsowanie zasilania ma wtedy 100Hz.
Wystarczy dodać, równolegle za mostkiem, kondensator elektrolitowy o dużej pojemności (>1000uF) i to powinno wygładzić przebieg zasilania diody.
Ostatnio zmieniony 05 cze 2014, 16:12 przez A_Tox, łącznie zmieniany 1 raz.
Awatar użytkownika
whosho
Posty: 821
Rejestracja: 09 kwie 2006, 11:49
Lokalizacja: Katowice
Kontaktowanie:

Re: Mruganie świateł na filmie z makiety

Postautor: whosho » 05 cze 2014, 07:54

Nie do końca masz rację.
Przy zasilaniu diod napięciem stałym nie ma prawa wystąpić żadne migotanie.
Przy zasilaniu napięciem zmiennym wyprostowanym jednopołówkowo dioda będzie migotała z częstotliwością 50Hz przy czym faktycznie świecić będzie przez mniej niż 50% okresu.
Przy wykorzystaniu mostka prostowniczego efekt będzie podobny -częstotliwość mrugania wzrośnie do 100Hz i wydłuży się czas świecenie diody.
Dopiero stabilizacja i filtrowanie wyprostowanego napięica pozwala uzyskać "kreche" ;)

I z takiej "krechy" (stabilizowanego napięcia stałego) "wycina się" krótki odcinki czasu w których napięcie jest zerowe (PWM). W Wajchowni częstotliwość PWM układu kontrolującego pracę sygnalizacji była dużo wyższa niż 25Hz, właśnie po to aby nie powodować efektu stroboskopowego.
Samowarek
Posty: 749
Rejestracja: 30 paź 2010, 02:05
Lokalizacja: Lublin
Been thanked: 2 times

Re: Mruganie świateł na filmie z makiety

Postautor: Samowarek » 04 cze 2014, 23:12

Jak mi się wydaje jedna dioda prostuje jedynie połowę sinusoidy prądu zmiennego przez co jest migotanie.Po zastosowaniu czterech czyli mostka Gretza prąd zostanie wyprostowany do linii prostej czyli gubimy tą migającą połowę.Na 100% nie jestem pewny ale chyba w tym jest metoda pozbycia się migotania a ze względu na brak takowej kamery nie można przeprowadzić eksperymentu potwierdzającego tego o czym wcześniej pisałem.Może ktoś kto posiada takową kamerę potwierdzi czy tak jest.Powodzenia :/
adamTT
Posty: 157
Rejestracja: 28 lut 2008, 21:19
Lokalizacja: Kalisz
Has thanked: 1 time

Re: Mruganie świateł na filmie z makiety

Postautor: adamTT » 04 cze 2014, 21:46

Semafory podłączone są do zwykłego zasilacza z regulacją napięcia - dawniej służący do regulacji prędkości lokomotywy (wiekowy zasilacz od NRD-owskiej kolejki)
Awatar użytkownika
Niejeden
Posty: 461
Rejestracja: 18 sie 2009, 20:47
Lokalizacja: Warszawa
Has thanked: 3 times
Been thanked: 4 times

Re: Mruganie świateł na filmie z makiety

Postautor: Niejeden » 04 cze 2014, 21:32

Ale tam masz jakiś driver do tych diod, czy po prostu większe napięcie dałeś?
adamTT
Posty: 157
Rejestracja: 28 lut 2008, 21:19
Lokalizacja: Kalisz
Has thanked: 1 time

Re: Mruganie świateł na filmie z makiety

Postautor: adamTT » 04 cze 2014, 21:13

ArturSchŁ pisze:Efekt płynnego gaszenia/zapalania uzyskujemy poprzez zmianę wypełnienia czasu zasilania LED.
Diody LED mają nieliniową krzywą jaskrawość/napięcie stąd nie da się ich płynnie zapalać/gasić poprzez zmianę napięcia STAŁEGO (od 0V do Umax).
By uzyskać płynne zapalanie stosujemy PWM czyli zmianę proporcji czasu zgaszony do zapalony, w jednym cyklu. Cykli jest ponad 20/sek. więc oko nie rozróżnia, że to miganie, tylko widzi ciągłe światło o jaskrawości proporcjonalnej do stosunku wypełnienia impulsu (ktoś to rozumie ? :) ).
hmmm, jeśli dobrze rozumiem, powyższe mogło by wyjaśnić dlaczego na niektórych filmach semafory na Grzybowie nie migają... przez pewien czas zwiększyłem jasność diod (większe napięcie), czyli wg tej teorii wypełniłem tym samym większą cześć cyklu jako zapalony, który nie pokrywał się z częstotliwością nagrywania przez kamerkę.
Ostatnio zmieniony 05 cze 2014, 08:42 przez adamTT, łącznie zmieniany 1 raz.
Awatar użytkownika
Misiek
Posty: 1519
Rejestracja: 23 kwie 2007, 22:26
Lokalizacja: Warszawa
Been thanked: 4 times
Kontaktowanie:

Re: Mruganie świateł na filmie z makiety

Postautor: Misiek » 04 cze 2014, 20:19

Tej nie polecam
Filmik wychodzi badziewnie a bateria padła po kilku użyciach.
https://www.youtube.com/watch?v=4qUUVzGRqCI
Ostatnio zmieniony 05 cze 2014, 08:41 przez Misiek, łącznie zmieniany 1 raz.
Awatar użytkownika
Niejeden
Posty: 461
Rejestracja: 18 sie 2009, 20:47
Lokalizacja: Warszawa
Has thanked: 3 times
Been thanked: 4 times

Re: Mruganie świateł na filmie z makiety

Postautor: Niejeden » 04 cze 2014, 19:07

ArturSchŁ pisze:By uzyskać płynne zapalanie stosujemy PWM czyli zmianę proporcji czasu zgaszony do zapalony, w jednym cyklu. Cykli jest ponad 20/sek. więc oko nie rozróżnia, że to miganie, tylko widzi ciągłe światło o jaskrawości proporcjonalnej do stosunku wypełnienia impulsu (ktoś to rozumie ? :) ).
Nadążam :) Dla zainteresowanych więcej tu: http://mikrokontrolery.blogspot.com/201 ... kiego.html

Odpowiadając na Twoje pytanie - czy LEDy w semaforach zasilane są z napięcia zasilania i następuje załączenie/wyłączenie Uzas przez np styki przekaźnika, czy może jest jakiś układ (płytka z prockiem i jakąś logiką stacji) pomiędzy zasilaniem, a semaforem ??
Na Mnichowie są semafory Viessmana: http://www.modelmania.com.pl/product_in ... s_id=25589
W zasilaniu świateł nie widać tam żadnej elektroniki, jedynie diodę prostowniczą.
Grzybowo ma sterowanie analogowe. PWM jest na Tarczynie (funkcja łagodnego zapalania diod w Wajchowni) ale tam akurat migania nie widać.
Ostatnio zmieniony 05 cze 2014, 08:40 przez Niejeden, łącznie zmieniany 2 razy.
Awatar użytkownika
ArturSchŁ
Administrator
Posty: 8273
Rejestracja: 09 kwie 2006, 07:22
Lokalizacja: Rumia
Has thanked: 32 times
Been thanked: 18 times
Kontaktowanie:

Re: Mruganie świateł na filmie z makiety

Postautor: ArturSchŁ » 04 cze 2014, 18:36

Efekt płynnego gaszenia/zapalania uzyskujemy poprzez zmianę wypełnienia czasu zasilania LED.
Diody LED mają nieliniową krzywą jaskrawość/napięcie stąd nie da się ich płynnie zapalać/gasić poprzez zmianę napięcia STAŁEGO (od 0V do Umax).
By uzyskać płynne zapalanie stosujemy PWM czyli zmianę proporcji czasu zgaszony do zapalony, w jednym cyklu. Cykli jest ponad 20/sek. więc oko nie rozróżnia, że to miganie, tylko widzi ciągłe światło o jaskrawości proporcjonalnej do stosunku wypełnienia impulsu (ktoś to rozumie ? :) ).
Np do uzyskania 10% jaskrawości LED jest zasilany przez 10% cyklu, a zgaszony przez 90% czasu cyklu ... itd. Cykl może trwać 1/20, 1/100 sekundy lub mniej.

Jeśli LED mruga (>20Hz) a kamera robi 20-30 klatek na sekundę to MUSI wystąpić interferencja tych dwóch częstotliwości objawiająca się mruganiem do nas "oczkiem" loki czy semafora świetlnego. Czyli powstaje efekt stroboskopowy. :lol:

Odpowiadając na Twoje pytanie - czy LEDy w semaforach zasilane są z napięcia zasilania i następuje załączenie/wyłączenie Uzas przez np styki przekaźnika, czy może jest jakiś układ (płytka z prockiem i jakąś logiką stacji) pomiędzy zasilaniem, a semaforem ??
Ostatnio zmieniony 04 cze 2014, 18:54 przez ArturSchŁ, łącznie zmieniany 7 razy.
Awatar użytkownika
Niejeden
Posty: 461
Rejestracja: 18 sie 2009, 20:47
Lokalizacja: Warszawa
Has thanked: 3 times
Been thanked: 4 times

Re: Mruganie świateł na filmie z makiety

Postautor: Niejeden » 04 cze 2014, 18:20

Ale na semaforze jest strob?
Awatar użytkownika
ArturSchŁ
Administrator
Posty: 8273
Rejestracja: 09 kwie 2006, 07:22
Lokalizacja: Rumia
Has thanked: 32 times
Been thanked: 18 times
Kontaktowanie:

Re: Mruganie świateł na filmie z makiety

Postautor: ArturSchŁ » 04 cze 2014, 18:13

Pamiętaj o interferencji częstotliwości klatek filmu z częstotliwością strobowania LEDów.
:mrgreen:

Mariusz pisze:... sam myślę o takiej.
np: http://allegro.pl/ak197-kamerka-szpiego ... 74451.html
Ostatnio zmieniony 04 cze 2014, 18:20 przez ArturSchŁ, łącznie zmieniany 2 razy.
Awatar użytkownika
Niejeden
Posty: 461
Rejestracja: 18 sie 2009, 20:47
Lokalizacja: Warszawa
Has thanked: 3 times
Been thanked: 4 times

Mruganie świateł na filmie z makiety

Postautor: Niejeden » 04 cze 2014, 17:19

Ciekawe zjawisko - na filmach LEDy na lokomotywach mrugają (cz. 6, 2:45) a na semaforach Mnichowa pulsują (cz. 2, początek). Na lokach domyślam się, że kamera "widzi" PWM ale na LEDach zasilanych prądem stałym?
Ostatnio zmieniony 04 cze 2014, 18:45 przez Niejeden, łącznie zmieniany 1 raz.

Wróć do „Elektryka i DCC”

Kto jest online

Użytkownicy przeglądający to forum: sn61 i 2 gości