Światła - ST43 od MTB

Prąd i elektronika na makiecie

Moderator: mod-Elektryka i DCC

ODPOWIEDZ
Awatar użytkownika
Skała
Posty: 303
Rejestracja: 19 maja 2006, 15:17
Lokalizacja: Nykøbing F.
Podziękował;: 7 razy
Otrzymał podziękowań: 11 razy
Kontakt:

Re: Światła - ST43 od MTB

Post autor: Skała »

Dzięki
PiotrZ
Posty: 630
Rejestracja: 09 kwie 2006, 09:35
Lokalizacja: Poznań
Podziękował;: 3 razy
Otrzymał podziękowań: 4 razy
Kontakt:

Re: Światła - ST43 od MTB

Post autor: PiotrZ »

Tak, MX630P16 (kupiony w dobrym czeskim sklepie za 120 PLN :-))
Awatar użytkownika
Skała
Posty: 303
Rejestracja: 19 maja 2006, 15:17
Lokalizacja: Nykøbing F.
Podziękował;: 7 razy
Otrzymał podziękowań: 11 razy
Kontakt:

Re: Światła - ST43 od MTB

Post autor: Skała »

Czy twój dekoder posiada nr katalogowy MX630P16? Pytam bo chcę zamówić.
PiotrZ
Posty: 630
Rejestracja: 09 kwie 2006, 09:35
Lokalizacja: Poznań
Podziękował;: 3 razy
Otrzymał podziękowań: 4 razy
Kontakt:

Re: Światła - ST43 od MTB

Post autor: PiotrZ »

No właśnie objawy były takie, jakby dekoder chciał tylko wysterować serwo i się wyłączał.
Ale problem już jest rozwiązany !! To ja przedobrzyłem z ustawieniami w dekoderze. Instrukcja do Zimo jest długa i zbyt wiele elementów pasowało do moich objawów.
Po resecie dekodera (pierwszy krok zaproponowany przez ArturaSch 8) ) ustawiłem tylko CV124 na wartość 128 i działa. Klawisz funkcyjny F5 zapala/gasi górny reflektor, a F6 zapala/gasi światło w kabinie

Dla potomnych krótkie podsumowanie :idea:
W analogu z zaślepką analogową:
- gdy jumper JP1 jest połączony, to świecą 3 reflektory zgodnie kierunkiem jazdy. Światło w kabinie nie świeci
- gdy jumper JP1 jest rozłączony, to świecą 2 dolne reflektory zgodnie kierunkiem jazdy. Reflektor górny i światło w kabinie nie świecą
W cyfrze z dekoderem jazdy Zimo MX630 Plux16:
- gdy jumper JP1 jest połączony, a dekoder ma ustawienia fabryczne, to świecą 3 reflektory oraz światło w kabinie (zgodnie kierunkiem jazdy)
- gdy jumper JP1 jest połączony, a dekoder ma ustawione CV124 na wartość 128, to świecą 3 reflektory, a światło w kabinie włącza się/wyłącza klawiszem F6 (ta opcja jest wg mnie najlepsza, bo nie ingeruje w hardware lokomotywy)
- gdy jumper JP1 jest rozłączony, a dekoder ma ustawione CV124 na wartość 128, to świecą 2 reflektory dolne. Reflektor górny włącza się/wyłącza klawiszem F5, a światło w kabinie włącza się/wyłącza klawiszem F6.

PS. O tych klawiszach F5/F6 wyczytałem w innej instrukcji do innej lokomotywy mtb: Pro aktivaci obou funkcí FO5,FO6 je nutné nejprve vypnout na DCC dekodéru komunikaci SUSI, která pouzívá tyto dva výstupy
Za ten post autor PiotrZ otrzymał podziękowania (total 2):
ArturSchŁ (21 lip 2020, 07:34) • Peter_KR (21 lip 2020, 14:36)
Ocena: 50%
Awatar użytkownika
wicy
Posty: 1519
Rejestracja: 23 mar 2014, 08:27
Lokalizacja: Łódź
Podziękował;: 45 razy
Otrzymał podziękowań: 36 razy
Kontakt:

Re: Światła - ST43 od MTB

Post autor: wicy »

PiotrZ pisze: Niestety teraz działa to tak, że obojętnie czy nacisnę F1 czy F2 to zawsze zapalają się jednocześnie i górny reflektor i lampa w kabinie, a na domiar złego po ok. 5 sekundach obie gasną !! :(
Pytania:
Jak rozdzielić górny reflektor od oświetlenia w kabinie (ewentualnie połączyć go z reflektorami dolnymi?
Jak włączać/wyłączać to oświetlenie na stałe?
Nie mam w tej chwili ST pod ręką, ale jedno jest pewne - wyłączanie czasowe nie zależy od PCB bo tam nie ma żadnych układów aktywnych. Problemu trzeba szukać w CV dekodera.
Wydaje mi się, że operując na SUSI jako serwo (wpisanie w CV181 i CV182 wartości różnej od 0), wyjście jest sterowane tak jak serwo. To że dioda świeci to tylko kwestia wypełnienia PWM. A że przestaje świecić = serwo stoi. Czas ruchu serwa ustalany jest w CV165 i wynosi ok 3 sek. Może właśnie dlatego led gaśnie.
Awatar użytkownika
ArturSchŁ
Administrator
Posty: 9368
Rejestracja: 09 kwie 2006, 07:22
Lokalizacja: Rumia
Podziękował;: 82 razy
Otrzymał podziękowań: 34 razy
Kontakt:

Re: Światła - ST43 od MTB

Post autor: ArturSchŁ »

Nie mam Rumina, wiec "gdybam".
PiotrZ pisze:Jak rozdzielić górny reflektor od oświetlenia w kabinie (ewentualnie połączyć go z reflektorami dolnymi?
Jak włączać/wyłączać to oświetlenie na stałe?
Wszystko zależy od PCB na pokładzie.
Dekoder zapala gasi układy podłączone do wyjść Fn. W zależności od realizacji sprzętowej (ścieżki, zworki, tranzystory-klucze) możliwe jest uzyskanie funkcjonalności zaprojektowanej przez producenta.

Możliwe jest uzyskanie dowolnej funkcjonalności, ale może być konieczne dokonanie zmian w połączeniach na PCB.

PS:
proponuję zacząć od resetu dekodera do nastaw fabrycznych i krok po kroku analizę co się dzieje przy zapaleniu pojedynczego Fn, później kombinacja dwóch, trzech itd.
Zimo: Normal" Funct. Outputs -> 6 , czyli do F6 max, jeśli dobrze rozumem zabawę z zmianą SUSI na F5/6 (choć nie sądzę by płytka obsługiwała więcej niż F4).
Po takim teście dojdziesz do wiedzy czym możesz sterować bez poprawek na PCB.
PiotrZ
Posty: 630
Rejestracja: 09 kwie 2006, 09:35
Lokalizacja: Poznań
Podziękował;: 3 razy
Otrzymał podziękowań: 4 razy
Kontakt:

Światła - ST43 od MTB

Post autor: PiotrZ »

Witam,
Mam pytanie do kolegów znających się na "prądzie" i CV-kach :) .
Otóż w końcu mój Rumun dostał dekoder jazdy Zimo MX630 Plux16. Loka jeździ i świeci, ale... świeciły się i reflektory i lampa w kabinie, więc zgodnie z oryginalną instrukcją przeciąłem zworkę na płytce (JP1) i góra zgasła.
Teraz żeby ją zapalić to - nadal zgodnie z instrukcją choć już niezbyt jasną - zmieniłem CV-ki:

CV124 ustawiłem Bit7=1, czyli wpisałem wartość 128 (bo to niby zmienia wyjścia SUSI z servo na logic)
CV181 wpisałem wartość 1, aby przycisk F1 włączał jedną diodę (np. górny reflektor)
CV182 wpisałem wartość 2, aby przycisk F2 włączał drugą diodę (np. oświetlenie w kabinie).

Niestety teraz działa to tak, że obojętnie czy nacisnę F1 czy F2 to zawsze zapalają się jednocześnie i górny reflektor i lampa w kabinie, a na domiar złego po ok. 5 sekundach obie gasną !! :(
Pytania:
Jak rozdzielić górny reflektor od oświetlenia w kabinie (ewentualnie połączyć go z reflektorami dolnymi?
Jak włączać/wyłączać to oświetlenie na stałe?
ODPOWIEDZ

Wróć do „Elektryka i DCC”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 0 gości